aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <me@robin-krahl.de>2018-12-11 23:51:40 +0100
committerDaniel Mueller <deso@posteo.net>2018-12-17 07:52:13 -0800
commit44f6100b36eecf79c1e8484a048ea49cad6e488d (patch)
treebf16ea9a570f3026324b9882f46b9f8360e7591f /nitrocli/Cargo.toml
parent6737f748b8edb5266c5397591b92da4c88f95dff (diff)
downloadnitrocli-44f6100b36eecf79c1e8484a048ea49cad6e488d.tar.gz
nitrocli-44f6100b36eecf79c1e8484a048ea49cad6e488d.tar.bz2
Remove unused dependencies
This patch removes all dependencies that are no longer required since the hidapi communication is replaced by libnitrokey. Delete subrepo hid/:hid Delete subrepo hidapi-sys/:hidapi-sys Delete subrepo pkg-config/:pkg-config
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml24
1 files changed, 0 insertions, 24 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 83e6888..8d1519a 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -32,38 +32,14 @@ description = """
A command line tool for interacting with the Nitrokey Storage device.
"""
-[dependencies.cc]
-version = "1.0"
-path = "../cc"
-
-[dependencies.hidapi-sys]
-version = "0.1"
-path = "../hidapi-sys"
-
-[dependencies.libc]
-version = "0.2"
-path = "../libc"
-
-[dependencies.libhid]
-version = "0.4"
-path = "../hid"
-package = "hid"
-
[dependencies.libnitrokey]
version = "0.2.1"
path = "../nitrokey"
package = "nitrokey"
-[dependencies.pkg-config]
-version = "0.3"
-path = "../pkg-config"
[replace]
"cc:1.0.25" = { path = "../cc" }
-"hidapi-sys:0.1.4" = { path = "../hidapi-sys" }
"libc:0.2.45" = { path = "../libc" }
-"libhid:0.4.1" = { path = "../hid" }
-"libnitrokey:0.2.1" = { path = "../nitrokey" }
"nitrokey-sys:3.4.1" = { path = "../nitrokey-sys" }
-"pkg-config:0.3.14" = { path = "../pkg-config" }
"rand:0.4.3" = { path = "../rand" }