aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2019-01-06 14:17:31 -0800
committerDaniel Mueller <deso@posteo.net>2019-01-06 14:17:31 -0800
commit0083f9dc7104dd21883451ad18c70758469ce1de (patch)
tree794a682bbd08804963d1d8662f3f0cf6ece0b5d1 /nitrocli/Cargo.toml
parent865f15edfdd7fca61b68da3c0aa3293dba630c81 (diff)
downloadnitrocli-0083f9dc7104dd21883451ad18c70758469ce1de.tar.gz
nitrocli-0083f9dc7104dd21883451ad18c70758469ce1de.tar.bz2
Use [patch] section to control local crate replacements
The nitrokey-sys crate poses a challenge in that upgrading it causes build errors caused by linking against the system's nitrokey library from multiple crates, which is not allowed. The exact cause of the problem is unclear but the suspicion is that a bug in Cargo's replacing logic is the cause of the issue. To work around this problem, this change switches to using the [patch] section for replacing crates with local copies instead of the [replace] one.
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 279c6c9..0128925 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -60,14 +60,14 @@ version = "0.1.1"
[dev-dependencies.regex]
version = "1"
-[replace]
-"argparse:0.2.2" = { path = "../argparse" }
-"base32:0.4.0" = { path = "../base32" }
-"cc:1.0.28" = { path = "../cc" }
-"libc:0.2.45" = { path = "../libc" }
-"nitrokey:0.3.1" = { path = "../nitrokey" }
-"nitrokey-sys:3.4.1" = { path = "../nitrokey-sys" }
-"rand:0.6.1" = { path = "../rand" }
-"rustc_version:0.2.3" = { path = "../rustc_version" }
-"semver:0.9.0" = { path = "../semver" }
-"semver-parser:0.7.0" = { path = "../semver-parser" }
+[patch.crates-io]
+argparse = { path = "../argparse" }
+base32 = { path = "../base32" }
+cc = { path = "../cc" }
+libc = { path = "../libc" }
+nitrokey = { path = "../nitrokey" }
+nitrokey-sys = { path = "../nitrokey-sys" }
+rand = { path = "../rand" }
+rustc_version = { path = "../rustc_version" }
+semver = { path = "../semver" }
+semver-parser = { path = "../semver-parser" }