aboutsummaryrefslogtreecommitdiff
path: root/lazy-static/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
committerDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
commitd0d9683df8398696147e7ee1fcffb2e4e957008c (patch)
tree4baa76712a76f4d072ee3936c07956580b230820 /lazy-static/Cargo.toml
parent203e691f46d591a2cc8acdfd850fa9f5b0fb8a98 (diff)
downloadnitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.gz
nitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.bz2
Remove vendored dependencies
While it appears that by now we actually can get successful builds without Cargo insisting on Internet access by virtue of using the --frozen flag, maintaining vendored dependencies is somewhat of a pain point. This state will also get worse with upcoming changes that replace argparse in favor of structopt and pull in a slew of new dependencies by doing so. Then there is also the repository structure aspect, which is non-standard due to the way we vendor dependencies and a potential source of confusion. In order to fix these problems, this change removes all the vendored dependencies we have. Delete subrepo argparse/:argparse Delete subrepo base32/:base32 Delete subrepo cc/:cc Delete subrepo cfg-if/:cfg-if Delete subrepo getrandom/:getrandom Delete subrepo lazy-static/:lazy-static Delete subrepo libc/:libc Delete subrepo nitrokey-sys/:nitrokey-sys Delete subrepo nitrokey/:nitrokey Delete subrepo rand/:rand
Diffstat (limited to 'lazy-static/Cargo.toml')
-rw-r--r--lazy-static/Cargo.toml34
1 files changed, 0 insertions, 34 deletions
diff --git a/lazy-static/Cargo.toml b/lazy-static/Cargo.toml
deleted file mode 100644
index 9c0a177..0000000
--- a/lazy-static/Cargo.toml
+++ /dev/null
@@ -1,34 +0,0 @@
-[package]
-name = "lazy_static"
-# NB: When modifying, also modify html_root_url in lib.rs
-version = "1.4.0"
-authors = ["Marvin Löbel <loebel.marvin@gmail.com>"]
-license = "MIT/Apache-2.0"
-
-description = "A macro for declaring lazily evaluated statics in Rust."
-readme = "README.md"
-documentation = "https://docs.rs/lazy_static"
-
-repository = "https://github.com/rust-lang-nursery/lazy-static.rs"
-keywords = ["macro", "lazy", "static"]
-categories = [ "no-std", "rust-patterns", "memory-management" ]
-exclude = ["/.travis.yml", "/appveyor.yml"]
-
-[dependencies.spin]
-version = "0.5.0"
-optional = true
-
-[features]
-spin_no_std = ["spin"]
-
-[dev-dependencies]
-doc-comment = "0.3.1"
-
-[badges]
-appveyor = { repository = "rust-lang-nursery/lazy-static.rs" }
-travis-ci = { repository = "rust-lang-nursery/lazy-static.rs" }
-
-is-it-maintained-issue-resolution = { repository = "rust-lang-nursery/lazy-static.rs" }
-is-it-maintained-open-issues = { repository = "rust-lang-nursery/lazy-static.rs" }
-
-maintenance = { status = "passively-maintained" }