aboutsummaryrefslogtreecommitdiff
path: root/getrandom/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
committerDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
commitd0d9683df8398696147e7ee1fcffb2e4e957008c (patch)
tree4baa76712a76f4d072ee3936c07956580b230820 /getrandom/Cargo.toml
parent203e691f46d591a2cc8acdfd850fa9f5b0fb8a98 (diff)
downloadnitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.gz
nitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.bz2
Remove vendored dependencies
While it appears that by now we actually can get successful builds without Cargo insisting on Internet access by virtue of using the --frozen flag, maintaining vendored dependencies is somewhat of a pain point. This state will also get worse with upcoming changes that replace argparse in favor of structopt and pull in a slew of new dependencies by doing so. Then there is also the repository structure aspect, which is non-standard due to the way we vendor dependencies and a potential source of confusion. In order to fix these problems, this change removes all the vendored dependencies we have. Delete subrepo argparse/:argparse Delete subrepo base32/:base32 Delete subrepo cc/:cc Delete subrepo cfg-if/:cfg-if Delete subrepo getrandom/:getrandom Delete subrepo lazy-static/:lazy-static Delete subrepo libc/:libc Delete subrepo nitrokey-sys/:nitrokey-sys Delete subrepo nitrokey/:nitrokey Delete subrepo rand/:rand
Diffstat (limited to 'getrandom/Cargo.toml')
-rw-r--r--getrandom/Cargo.toml45
1 files changed, 0 insertions, 45 deletions
diff --git a/getrandom/Cargo.toml b/getrandom/Cargo.toml
deleted file mode 100644
index b159674..0000000
--- a/getrandom/Cargo.toml
+++ /dev/null
@@ -1,45 +0,0 @@
-[package]
-name = "getrandom"
-version = "0.1.13"
-edition = "2018"
-authors = ["The Rand Project Developers"]
-license = "MIT OR Apache-2.0"
-description = "A small cross-platform library for retrieving random data from system source"
-documentation = "https://docs.rs/getrandom"
-repository = "https://github.com/rust-random/getrandom"
-categories = ["os", "no-std"]
-exclude = ["utils/*", ".*", "appveyor.yml"]
-
-[badges]
-travis-ci = { repository = "rust-random/getrandom" }
-appveyor = { repository = "rust-random/getrandom" }
-
-[dependencies]
-log = { version = "0.4", optional = true }
-cfg-if = "0.1.2"
-
-# When built as part of libstd
-compiler_builtins = { version = "0.1", optional = true }
-core = { version = "1.0", optional = true, package = "rustc-std-workspace-core" }
-
-[target.'cfg(unix)'.dependencies]
-libc = { version = "0.2.64", default-features = false }
-
-[target.'cfg(target_os = "wasi")'.dependencies]
-wasi = "0.7"
-
-[target.wasm32-unknown-unknown.dependencies]
-wasm-bindgen = { version = "0.2.29", optional = true }
-stdweb = { version = "0.4.18", optional = true }
-
-[target.wasm32-unknown-unknown.dev-dependencies]
-wasm-bindgen-test = "0.2"
-
-[features]
-std = []
-# Enables dummy implementation for unsupported targets
-dummy = []
-# Unstable feature to support being a libstd dependency
-rustc-dep-of-std = ["compiler_builtins", "core"]
-# Unstable feature for testing
-test-in-browser = ["wasm-bindgen"]