aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-01-23 14:04:42 +0100
committerDaniel Mueller <deso@posteo.net>2020-09-01 21:12:56 -0700
commitbd704881145d3586f9a3cf9b171121b02e54f1ee (patch)
tree2f78b8df1478dca754e341926a92a42cb266ae37 /Cargo.toml
parent3f430bac70a946c776a930fabc5b64a788113452 (diff)
downloadnitrocli-bd704881145d3586f9a3cf9b171121b02e54f1ee.tar.gz
nitrocli-bd704881145d3586f9a3cf9b171121b02e54f1ee.tar.bz2
Use envy to parse environment variables for Config
This patch uses the envy crate to parse the environment. A variable NITROCLI_KEY can be used to overwrite the configuration for *key*. This has the side effect that the NITROCLI_NO_CACHE variable is evaluated as a boolean variable (instead of only checking whether it is set). We also accept two new variables, NITROCLI_MODEL and NITROCLI_VERBOSITY.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d652cba..493e0c5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,9 +52,15 @@ version = "1.0"
[dependencies.base32]
version = "0.4.0"
+[dependencies.envy]
+version = "0.4.1"
+
[dependencies.libc]
version = "0.2"
+[dependencies.merge]
+version = "0.1"
+
[dependencies.nitrokey]
version = "0.7.1"