aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-01-23 10:54:09 +0100
committerDaniel Mueller <deso@posteo.net>2020-09-01 21:12:43 -0700
commit3f430bac70a946c776a930fabc5b64a788113452 (patch)
treeb1989fd259a159eb7982002155dc8b482948c1cd /Cargo.toml
parentbb592ad9909c84c3c72252e1775b1cd2abc1e881 (diff)
downloadnitrocli-3f430bac70a946c776a930fabc5b64a788113452.tar.gz
nitrocli-3f430bac70a946c776a930fabc5b64a788113452.tar.bz2
Implement configuration handling
This patch implements basic configuration handling that reads a configuration file and stores the parsed data in the ExecCtx and RunCtx structs. It supports three configuration items: - model (previously only --model) - no_cache (previously only NITROCLI_NO_CACHE) - verbosity (previously only --verbose)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 961e82f..d652cba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -58,10 +58,17 @@ version = "0.2"
[dependencies.nitrokey]
version = "0.7.1"
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
[dependencies.structopt]
version = "0.3.7"
default-features = false
+[dependencies.toml]
+version = "0.5.6"
+
[dev-dependencies.nitrokey-test]
version = "0.4"