aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-01-23 14:04:42 +0100
committerDaniel Mueller <deso@posteo.net>2020-09-05 11:35:28 -0700
commitb4b7605e1f947ef0c58d94354c10fd74fd010a53 (patch)
treefec9d30417cb91f92f4e2e67e151d2ad9c3517ec /Cargo.toml
parent88b243bca17ab549342738bce98a1c678f98e754 (diff)
downloadnitrocli-b4b7605e1f947ef0c58d94354c10fd74fd010a53.tar.gz
nitrocli-b4b7605e1f947ef0c58d94354c10fd74fd010a53.tar.bz2
Use envy to parse environment variables for Config
This patch uses the envy crate to parse the environment. A variable NITROCLI_KEY can be used to overwrite the configuration for *key*. This has the side effect that the NITROCLI_NO_CACHE variable is evaluated as a boolean variable (instead of only checking whether it is set). We also accept two new variables, NITROCLI_MODEL and NITROCLI_VERBOSITY.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 23602ec..2e2e47f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,9 +52,15 @@ version = "1.0"
[dependencies.base32]
version = "0.4.0"
+[dependencies.envy]
+version = "0.4.1"
+
[dependencies.libc]
version = "0.2"
+[dependencies.merge]
+version = "0.1"
+
[dependencies.nitrokey]
version = "0.7.1"