aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-01-23 10:54:09 +0100
committerDaniel Mueller <deso@posteo.net>2020-09-05 11:35:11 -0700
commit88b243bca17ab549342738bce98a1c678f98e754 (patch)
treee1887917dc1eb94a23642ebe26b2f6c02b705188 /Cargo.toml
parent887f3cb9aab12b390ae9efe09c1ff7f972e51c35 (diff)
downloadnitrocli-88b243bca17ab549342738bce98a1c678f98e754.tar.gz
nitrocli-88b243bca17ab549342738bce98a1c678f98e754.tar.bz2
Implement configuration handling
This patch implements basic configuration handling that reads a configuration file and stores the parsed data in the ExecCtx and RunCtx structs. It supports three configuration items: - model (previously only --model) - no_cache (previously only NITROCLI_NO_CACHE) - verbosity (previously only --verbose)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fcc1a6d..23602ec 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -58,10 +58,17 @@ version = "0.2"
[dependencies.nitrokey]
version = "0.7.1"
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
[dependencies.structopt]
version = "0.3.7"
default-features = false
+[dependencies.toml]
+version = "0.5.6"
+
[dev-dependencies.nitrokey-test]
version = "0.4"