aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-09-10 12:39:07 +0200
committerDaniel Mueller <deso@posteo.net>2020-09-12 14:31:46 -0700
commit57a177e2f946390559a1f17787c5a15d23ac3393 (patch)
treea8069b927bdda75fbceb9e7a289d8338bb19fd8b /Cargo.toml
parent33918c32b8de4250c450f8d0b007019913c440a1 (diff)
downloadnitrocli-57a177e2f946390559a1f17787c5a15d23ac3393.tar.gz
nitrocli-57a177e2f946390559a1f17787c5a15d23ac3393.tar.bz2
Show progress bar in fill output
This patch uses the progressing crate to display a progress bar for the fill command if the output is printed to a TTY.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8ffa07d..a24cc81 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -53,6 +53,9 @@ version = "0.1"
[dependencies.nitrokey]
version = "0.7.1"
+[dependencies.progressing]
+version = "3.0.2"
+
[dependencies.serde]
version = "1.0"
features = ["derive"]