aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-09-10 13:34:46 +0200
committerDaniel Mueller <deso@posteo.net>2020-09-12 14:12:04 -0700
commit33918c32b8de4250c450f8d0b007019913c440a1 (patch)
tree2fb69aaa8456066de582c300de6f240c085a5ee5 /Cargo.toml
parentca737e96c7688cc214e9cb514b18861b4671651c (diff)
downloadnitrocli-33918c32b8de4250c450f8d0b007019913c440a1.tar.gz
nitrocli-33918c32b8de4250c450f8d0b007019913c440a1.tar.bz2
Add is_tty field to Context
This patch adds the is_tty field to the Context struct that indicates whether stdout is a TTY. This allows us to use TTY features like moving the cursor in our output.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43ff6cb..8ffa07d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -61,6 +61,9 @@ features = ["derive"]
version = "0.3.17"
default-features = false
+[dependencies.termion]
+version = "1.5.5"
+
[dependencies.toml]
version = "0.5.6"