aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-07-17 19:50:06 -0700
committerDaniel Mueller <deso@posteo.net>2020-07-17 19:50:06 -0700
commit11344455b0629f989d8b78c27ed0e7d654fc74ef (patch)
tree14173b0ca579993bc2092c78b0b7ef55891b9130 /Cargo.toml
parent72628e1f12a2da09d4c5fca902e1fb16c494796d (diff)
downloadnitrocli-11344455b0629f989d8b78c27ed0e7d654fc74ef.tar.gz
nitrocli-11344455b0629f989d8b78c27ed0e7d654fc74ef.tar.bz2
Update nitrokey dependency to 0.7.1
This change updates the nitrokey dependency we consume to 0.7.1. With this version the crate's Error type got reworked slightly, allowing it to implement Sync and Send. It furthermore no longer duplicates information available through the source() method in its Display implementation. Both these changes will enable us to switch over to using the anyhow crate for error handling in nitrocli in the future.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b5e5e5c..548199b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -53,7 +53,7 @@ version = "0.4.0"
version = "0.2"
[dependencies.nitrokey]
-version = "0.6"
+version = "0.7.1"
[dependencies.structopt]
version = "0.3.7"