aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIgor Gnatenko <i.gnatenko.brain@gmail.com>2018-07-18 13:52:16 +0200
committerIgor Gnatenko <i.gnatenko.brain@gmail.com>2018-07-18 13:54:51 +0200
commit968b4027f4f13ebc311c3aab741fbc2eea50cca3 (patch)
treec0d19346fe7ba77bb042aa88d2d29578f51b9a76 /meson.build
parent586be530f0782499088708e34cf05073924ecb9c (diff)
downloadlibnitrokey-968b4027f4f13ebc311c3aab741fbc2eea50cca3.tar.gz
libnitrokey-968b4027f4f13ebc311c3aab741fbc2eea50cca3.tar.bz2
meson: add support for bundled catch
Better to use meson's subproject, but let's go with submodule for now. Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c81fbbf..b14fe0c 100644
--- a/meson.build
+++ b/meson.build
@@ -113,7 +113,12 @@ pkg.generate(
)
if get_option('tests') or get_option('offline-tests')
- dep_catch = dependency('catch')
+ dep_catch = dependency('catch', required : false)
+ if not dep_catch.found()
+ dep_catch = declare_dependency(
+ include_directories : include_directories('unittest/Catch/single_include')
+ )
+ endif
_catch = static_library(
'catch',
sources : [