aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSzczepan Zalega <szczepan@nitrokey.com>2019-01-24 18:43:19 +0100
committerSzczepan Zalega <szczepan@nitrokey.com>2019-01-24 18:43:19 +0100
commitf7cbdc09858b7d26765e819c89e4289d30877f74 (patch)
treed6f9b5046e86501ab5b0ecc3c1ec3688e22a0307 /CMakeLists.txt
parent8e4c28de760033dde2469bb69b76a80076d0fc39 (diff)
parentaf8ee6d30ac8ae45cf440c6bc2e03a873e3db584 (diff)
downloadlibnitrokey-f7cbdc09858b7d26765e819c89e4289d30877f74.tar.gz
libnitrokey-f7cbdc09858b7d26765e819c89e4289d30877f74.tar.bz2
Merge branch 'pr_148'
Generate documentation for C API using Doxygen Fixes #148
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57ed28f..7ba6f9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -233,3 +233,12 @@ set (CPACK_RESOURCE_FILE_LICENSE
"${CMAKE_CURRENT_SOURCE_DIR}/LICENSE")
set (CPACK_PACKAGE_VERSION "${PROJECT_VERSION}")
include (CPack)
+
+# Build Doxygen documentation for the C API
+find_package(Doxygen)
+if (DOXYGEN_FOUND)
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile @ONLY)
+ add_custom_target(doc ${DOXYGEN_EXECUTABLE} Doxyfile
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating C API documentation with Doxygen" VERBATIM)
+endif(DOXYGEN_FOUND)