aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-03-11 11:31:57 +0100
committerSzczepan Zalega <szczepan@nitrokey.com>2018-03-13 09:37:35 +0100
commit15dc909b1bd2621b64c7fd58a7cf55a4778876cf (patch)
tree527ebfbade550a70c3794308e7e93b8085624d5c /CMakeLists.txt
parent350fa7670ff63d0833d80edee42c1a798c3064c3 (diff)
downloadlibnitrokey-15dc909b1bd2621b64c7fd58a7cf55a4778876cf.tar.gz
libnitrokey-15dc909b1bd2621b64c7fd58a7cf55a4778876cf.tar.bz2
Make unbundling easier
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 17 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6037393..43250b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,23 +42,23 @@ ENDIF()
MESSAGE("${PROJECT_NAME}: Build type: ${CMAKE_BUILD_TYPE}")
include_directories(hidapi)
-include_directories(include)
+include_directories(libnitrokey)
set(SOURCE_FILES
- include/command.h
- include/command_id.h
- include/cxx_semantics.h
- include/device.h
- include/device_proto.h
- include/dissect.h
- include/log.h
- include/misc.h
- include/NitrokeyManager.h
- include/stick10_commands.h
- include/stick20_commands.h
- include/CommandFailedException.h
- include/LibraryException.h
- include/LongOperationInProgressException.h
- include/stick10_commands_0.8.h
+ libnitrokey/command.h
+ libnitrokey/command_id.h
+ libnitrokey/cxx_semantics.h
+ libnitrokey/device.h
+ libnitrokey/device_proto.h
+ libnitrokey/dissect.h
+ libnitrokey/log.h
+ libnitrokey/misc.h
+ libnitrokey/NitrokeyManager.h
+ libnitrokey/stick10_commands.h
+ libnitrokey/stick20_commands.h
+ libnitrokey/CommandFailedException.h
+ libnitrokey/LibraryException.h
+ libnitrokey/LongOperationInProgressException.h
+ libnitrokey/stick10_commands_0.8.h
command_id.cc
device.cc
log.cc
@@ -115,7 +115,7 @@ IF (LOG_VOLATILE_DATA)
ENDIF()
-file(GLOB LIB_INCLUDES "include/*.h" "NK_C_API.h")
+file(GLOB LIB_INCLUDES "libnitrokey/*.h" "NK_C_API.h")
install (FILES ${LIB_INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${PROJECT_NAME})
install (TARGETS nitrokey DESTINATION ${CMAKE_INSTALL_LIBDIR})