aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-01-11 02:31:29 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-01-11 03:32:45 +0100
commit84bfea7add93a98f83ad958151cca718c33bc0a4 (patch)
treecd860c19962398c06b17f383931441787a6e786e /Cargo.toml
parentdc754cbc9763b3ea6979ed55bd4e8030fe073078 (diff)
downloaddialog-rs-84bfea7add93a98f83ad958151cca718c33bc0a4.tar.gz
dialog-rs-84bfea7add93a98f83ad958151cca718c33bc0a4.tar.bz2
Add the stdio backend
This patch adds the stdio backend which acts as a fallback backend and uses standard input and output. For password queries, the rpassword crate is used to suppress output. Also, default_backend is changed to return Stdio if Dialog is not available.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1a6c816..a4087a8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,3 +12,4 @@ readme = "README.md"
license = "MIT"
[dependencies]
+rpassword = "2"