summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorjelemux <jeremias.weber@protonmail.com>2020-10-18 22:40:57 +0200
committerjelemux <jeremias.weber@protonmail.com>2020-10-18 22:40:57 +0200
commit84c2dab4200c37c818d83c95f85445ee00d83bf6 (patch)
tree134d9ec538306a6626d35e737035e03c8b3a69c5 /Cargo.toml
downloadwasm-card-84c2dab4200c37c818d83c95f85445ee00d83bf6.tar.gz
wasm-card-84c2dab4200c37c818d83c95f85445ee00d83bf6.tar.bz2
initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2eaf0bf
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "bcard-wasm-webapp"
+version = "0.1.0"
+authors = ["jelemux <jeremias.weber@protonmail.com>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
+[dependencies]
+yew = "0.17.3" # react-like frontend framework
+wasm-bindgen = "0.2.68" # enables interaction with js
+chrono = "0.4.19" # date & time
+genpdf = { path = "../genpdf-rs" } # pdf generation \ No newline at end of file