summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorjelemux <jeremias.weber@protonmail.com>2020-10-21 22:01:59 +0200
committerjelemux <jeremias.weber@protonmail.com>2020-10-21 22:01:59 +0200
commit10eb0e8cff7f0bc6b61a77a179fec55ee1dfe929 (patch)
tree7c3c3b4ed11e723fb5c55091af7d33440783f52b /Cargo.toml
parentf267433455dbc69e771b06dd7c433c90ad978d33 (diff)
downloadwasm-card-10eb0e8cff7f0bc6b61a77a179fec55ee1dfe929.tar.gz
wasm-card-10eb0e8cff7f0bc6b61a77a179fec55ee1dfe929.tar.bz2
basic prototype with vcard and pdf generation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 12 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e22fc82..bda1251 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,11 +10,16 @@ edition = "2018"
crate-type = ["cdylib", "rlib"]
[dependencies]
-yew = "0.17.4" # react-like frontend framework
-wasm-bindgen = "0.2.68" # enables interaction with js
-chrono = "0.4.19" # date & time
-genpdf = { path = "../genpdf-rs" } # pdf generation
-js-sys = "0.3.45" # raw bindings to js global apis
+yew = "0.17.4"
+wasm-bindgen = "0.2.68"
+genpdf = { path = "../genpdf-rs" }
+js-sys = "0.3.45"
printpdf = "0.3.3"
-web-sys = "0.3.45"
-base64 = "0.13.0" \ No newline at end of file
+base64 = "0.13.0"
+vcard = "0.4.7"
+console_error_panic_hook = "0.1.6"
+
+[dependencies.chrono]
+version = "0.4.19"
+default-features = false
+features = ["wasmbind", "js-sys"] \ No newline at end of file