aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2020-09-22 19:09:40 +0200
committerRobin Krahl <robin.krahl@ireas.org>2020-09-22 19:09:40 +0200
commitc484777f3a7dde9e9fe8f47344fd8a6b30840b78 (patch)
tree3d6c111f619e8b2b428e9a1744a9dc15b4f1ca3d /Cargo.toml
parent4932d2376cc03c64eb82972824be673cdc2e0741 (diff)
downloadnitrokey-sys-rs-c484777f3a7dde9e9fe8f47344fd8a6b30840b78.tar.gz
nitrokey-sys-rs-c484777f3a7dde9e9fe8f47344fd8a6b30840b78.tar.bz2
Add feature to generate bindings during build
This patch adds the bindgen feature to the crate that allows users to re-generate the bindings, including layout tests, during the build instead of using the pre-generated bindings. Per default, this feature is disabled.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 068670b..99b2afd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,4 +13,8 @@ build = "build.rs"
readme = "README.md"
[build-dependencies]
+bindgen = { version = "0.55.1", optional = true }
cc = "1.0"
+
+[features]
+default = []