aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c37e31..b840e07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,7 +54,9 @@ set(SOURCE_FILES
add_library(nitrokey SHARED ${SOURCE_FILES})
+add_library(nitrokey-static STATIC ${SOURCE_FILES})
target_link_libraries(nitrokey hidapi-libusb)
+target_link_libraries(nitrokey-static hidapi-libusb)
install (TARGETS nitrokey DESTINATION "lib")
file(GLOB LIB_INCLUDES "include/libnitrokey/*.h")