aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ed907b..d0bc1f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,8 @@ IF (UNIX)
ENDIF()
IF(ADD_TSAN)
SET(EXTRA_LIBS ${EXTRA_LIBS} tsan )
- ADD_DEFINITIONS(-fsanitize=thread -fno-omit-frame-pointer -fPIE -pie -g)
+ SET(USE_CLANG TRUE)
+ ADD_DEFINITIONS(-fsanitize=thread -fno-omit-frame-pointer -fPIC -g) #use with clang
ENDIF()
IF(ADD_TSAN AND ADD_ASAN)
message(FATAL_ERROR "TSAN and ASAN cannot be used at the same time")