aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSzczepan Zalega <szczepan@nitrokey.com>2018-07-24 10:28:45 +0200
committerSzczepan Zalega <szczepan@nitrokey.com>2018-07-24 10:28:45 +0200
commit2ebf30d87dc0b9bcc9488afab441e31044ec7ffa (patch)
tree2b23fca870eacbab42191f2e696061ec1645fceb /meson.build
parent6984151c61a85e10e93946f506b2f65b9dd9ec1b (diff)
parent8de3f4d145c8f0321164afdcd1fa3d0e0c374e97 (diff)
downloadlibnitrokey-2ebf30d87dc0b9bcc9488afab441e31044ec7ffa.tar.gz
libnitrokey-2ebf30d87dc0b9bcc9488afab441e31044ec7ffa.tar.bz2
Merge branch 'pr_132'
Update Catch to 2.3.0 Both CMake and Meson build files updated. Tests compile (with both) and run with a Storage device. Fixes #132
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f3be6b3..600be6d 100644
--- a/meson.build
+++ b/meson.build
@@ -120,7 +120,7 @@ install_data(
)
if get_option('tests') or get_option('offline-tests')
- dep_catch = dependency('catch', required : false)
+ dep_catch = dependency('catch2', version : '>=2.3.0', required : false)
if not dep_catch.found()
dep_catch = declare_dependency(
include_directories : include_directories('unittest/Catch/single_include')