aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSzczepan Zalega <szczepan@nitrokey.com>2017-02-06 12:12:13 +0100
committerSzczepan Zalega <szczepan@nitrokey.com>2017-03-11 15:41:43 +0100
commit9c24f835372cc28d255557bd00f9d28598a07ebe (patch)
tree9209e547b5314a423aa2fd928fb903bf42394aa5 /CMakeLists.txt
parent473f1bf1854305c6ab5e926f369d07a37e081f3c (diff)
downloadlibnitrokey-9c24f835372cc28d255557bd00f9d28598a07ebe.tar.gz
libnitrokey-9c24f835372cc28d255557bd00f9d28598a07ebe.tar.bz2
Build Release with debug info when none build type selected
Signed-off-by: Szczepan Zalega <szczepan@nitrokey.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 21fe7ab..6ed4498 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,8 +19,9 @@ project(libnitrokey CXX)
set(CMAKE_CXX_STANDARD 14)
OPTION(COMPILE_TESTS "Compile tests" FALSE)
-set(CMAKE_BUILD_TYPE RelWithDebInfo)
-
+IF (NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE RelWithDebInfo)
+ENDIF()
MESSAGE("Build type: ${CMAKE_BUILD_TYPE}")
include_directories(include)