aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSzczepan Zalega <szczepan@nitrokey.com>2016-10-14 14:01:10 +0200
committerSzczepan Zalega <szczepan@nitrokey.com>2016-10-19 16:34:34 +0200
commit5e72941919f19c43c1cd7f79c5cb913caf2705e4 (patch)
treed83ced389eb5a34bba49295fc8c250a586d8b3d7 /CMakeLists.txt
parent6f2769cb57c06d4ee10532b80482b8610aae4f2b (diff)
downloadlibnitrokey-5e72941919f19c43c1cd7f79c5cb913caf2705e4.tar.gz
libnitrokey-5e72941919f19c43c1cd7f79c5cb913caf2705e4.tar.bz2
Test C API in C++ (Catch)
Signed-off-by: Szczepan Zalega <szczepan@nitrokey.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 803c465..eedfd35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,8 @@ set(SOURCE_FILES
log.cc
misc.cc
NitrokeyManager.cc
- NK_C_API.cc include/CommandFailedException.h include/LibraryException.h)
+ NK_C_API.cc include/CommandFailedException.h include/LibraryException.h
+ unittest/test_C_API.cpp
+ unittest/catch_main.cpp)
add_executable(libnitrokey ${SOURCE_FILES}) \ No newline at end of file