aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSzczepan Zalega <szczepan@nitrokey.com>2017-10-03 18:09:49 +0200
committerSzczepan Zalega <szczepan@nitrokey.com>2017-10-03 18:09:49 +0200
commit7f7cfeb45b579204e0bc94bea37e2c810d2e5ec9 (patch)
tree4058c41e2460fad253ec0290a56166e46a28bc78 /CMakeLists.txt
parent8f7435e4553916e6cc431e4b5316cc5861fd9063 (diff)
parent7d0d03428f90d3f65452eb7035bb715efec87ac8 (diff)
downloadlibnitrokey-7f7cfeb45b579204e0bc94bea37e2c810d2e5ec9.tar.gz
libnitrokey-7f7cfeb45b579204e0bc94bea37e2c810d2e5ec9.tar.bz2
Merge branch 'OSX_merge_cleaned'
This merge: - fixes issues with invalid mutex - moves tests to Python 3 - allows to compile the code natively under Visual Studio with CMake - allows to compile under QtCreator under MS Windows - fixes some issues with test suite - allows to run tests under Windows - allows to compile using QMake (and easy adding to Qt projects) - decreases delays between sending commands thus increasing 2x communication speed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6741b18..11882f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,8 @@
+# https://cmake.org/pipermail/cmake/2011-May/044166.html
+ IF(NOT DEFINED CMAKE_INSTALL_SYSTEM_RUNTIME_LIBS_NO_WARNINGS)
+ SET(CMAKE_INSTALL_SYSTEM_RUNTIME_LIBS_NO_WARNINGS ON)
+ ENDIF()
+
cmake_minimum_required(VERSION 3.1)
IF (UNIX)
OPTION(USE_CLANG "Use CLang" FALSE)
@@ -111,7 +116,7 @@ install (FILES ${LIB_INCLUDES} DESTINATION "include")
IF (COMPILE_TESTS)
include_directories(unittest/Catch/include)
- add_library(catch SHARED unittest/catch_main.cpp )
+ add_library(catch STATIC unittest/catch_main.cpp )
add_executable (test_C_API unittest/test_C_API.cpp)
target_link_libraries (test_C_API ${EXTRA_LIBS} ${LIBNAME}-log catch)