aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobin Krahl <me@robin-krahl.de>2018-07-05 22:44:35 +0200
committerRobin Krahl <me@robin-krahl.de>2018-07-05 22:50:51 +0200
commit63013dee539b33c682dd46ae4a086b2f75f46f16 (patch)
tree74416caef4a38ea3dfeefb967e3d50f2c0e0b727 /CMakeLists.txt
parent494f5b3c285bf4b42c57e85f3b7b7e26620378e8 (diff)
downloadlibnitrokey-63013dee539b33c682dd46ae4a086b2f75f46f16.tar.gz
libnitrokey-63013dee539b33c682dd46ae4a086b2f75f46f16.tar.bz2
Add a test to ensure valid C code in the C API
All current tests are written in C++. Therefore C++-only code in the C API might not be detected by the tests. This patch adds a minimal test written in C that only includes the C API header. This should make sure that the C API code is valid. The new test is called `test_minimal.c` and is added to the CMake COMPILE_OFFLINE_TESTS option.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06ab448..43d15df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -178,6 +178,10 @@ IF(COMPILE_OFFLINE_TESTS)
#run with 'make test' or 'ctest'
include (CTest)
add_test (runs test_offline)
+
+ add_executable(test_minimal unittest/test_minimal.c)
+ target_link_libraries(test_minimal ${EXTRA_LIBS} nitrokey)
+ add_test(minimal test_minimal)
ENDIF()
IF (COMPILE_TESTS)