summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d871b5c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# Copyright (C) 2018 Robin Krahl <robin.krahl@ireas.org>
+# SPDX-License-Identifier: MIT
+
+import setuptools
+
+
+setuptools.setup(
+ name='bibtool',
+ version='0.0.1',
+ description='bibliography management tool',
+ author='Robin Krahl',
+ author_email='robin.krahl@ireas.org',
+ license='MIT',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'License :: OSI Approvied :: MIT License',
+ 'Programming Language :: Python :: 3',
+ ],
+ packages=['bibtool'],
+ install_requires=['bibtexparser', 'click', 'PyPDF2'],
+ extras_require={
+ 'checkstyle': ['flake8'],
+ },
+ entry_points={
+ 'console_scripts': [
+ 'bibtool=bibtool.cli:cli',
+ ],
+ },
+)