aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..652f454
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "nitrokey"
+version = "0.1.0"
+authors = ["Robin Krahl <robin.krahl@ireas.org>"]
+homepage = "https://code.ireas.org/nitrokey-rs/"
+repository = "https://git.ireas.org/nitrokey-rs/"
+description = "Bindings to libnitrokey for communication with Nitrokey devices"
+keywords = ["nitrokey", "otp"]
+categories = ["api-bindings"]
+license = "MIT"
+
+[features]
+default = ["test-no-device"]
+test-no-device = []
+test-pro = []
+
+[dependencies]
+libc = "0.2"
+nitrokey-sys = { path = "nitrokey-sys" }
+rand = "0.4"