aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 238cc02..b57591b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,9 @@
+# Copyright (C) 2019-2020 Robin Krahl <robin.krahl@ireas.org>
+# SPDX-License-Identifier: CC0-1.0
+
[package]
name = "nitrokey"
-version = "0.3.5"
+version = "0.4.0"
authors = ["Robin Krahl <robin.krahl@ireas.org>"]
edition = "2018"
homepage = "https://code.ireas.org/nitrokey-rs/"
@@ -11,16 +14,14 @@ keywords = ["nitrokey", "otp"]
categories = ["api-bindings"]
readme = "README.md"
license = "MIT"
-
-[features]
-test-pro = []
-test-storage = []
+exclude = [".builds/*"]
[dependencies]
+lazy_static = "1.2"
libc = "0.2"
-nitrokey-sys = "~3.4"
-rand_core = {version = "0.3", default-features = false}
-rand_os = {version = "0.1"}
+nitrokey-sys = "3.5"
+rand_core = {version = "0.5.1", features = ["getrandom"] }
[dev-dependencies]
-nitrokey-test = {version = "0.1"}
+nitrokey-test = "0.3"
+nitrokey-test-state = "0.1"