aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-07-05 22:59:27 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-07-05 23:03:37 +0000
commite923c8b1ddaeafc9494ae86738bed9ad0e0e6e8f (patch)
treefa1e771be72a5b6954b546e85e74d9859deb144f /Cargo.toml
parent381666ed17e0d85293f52493f852480bee70783b (diff)
downloadnitrokey-rs-e923c8b1ddaeafc9494ae86738bed9ad0e0e6e8f.tar.gz
nitrokey-rs-e923c8b1ddaeafc9494ae86738bed9ad0e0e6e8f.tar.bz2
Update nitrokey-sys to version 3.5
As the return type of the NK_get_{major,minor}_firmware_version methods changed with libnitrokey 3.5, we also have to adapt our get_firmware_version function in device.rs. This patch also updates the changelog and the todo list with the changes caused by the new libnitrokey version.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 355f001..83cfa9f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ exclude = [".builds/*"]
[dependencies]
libc = "0.2"
-nitrokey-sys = "~3.4"
+nitrokey-sys = "3.5"
rand_core = {version = "0.3", default-features = false, features = ["std"] }
rand_os = {version = "0.1"}