aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2019-01-14 10:35:52 -0800
committerRobin Krahl <robin.krahl@ireas.org>2019-01-14 20:30:59 +0100
commit77aa0e51962880c170d924fa735f2268772a0652 (patch)
treee7b7286978d41f72894035f02a65ccbdd7a075df /Cargo.toml
parentc34b56b2b4c317947fd8fd3ae6c1fa3a773ee775 (diff)
downloadnitrokey-rs-77aa0e51962880c170d924fa735f2268772a0652.tar.gz
nitrokey-rs-77aa0e51962880c170d924fa735f2268772a0652.tar.bz2
Use rand_os for random data generation
The rand crate comes with a slew of dependencies to cover all sort of randomness related tasks in various scenarios. However, this crate really only requires a tiny subset of this functionality. As it turns out, this core functionality is provided by the rand_os crate. This change drops the dependency to rand in favor of rand_os. In order to accomplish that, it brings back the RngError variant for the CommandError enum to capture the possibility of the creation of the random number generator failing.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 09811f0..ba0923e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,8 @@ test-storage = []
[dependencies]
libc = "0.2"
nitrokey-sys = "3.4"
-rand = "0.6"
+rand_core = {version = "0.3", default-features = false}
+rand_os = {version = "0.1"}
[dev-dependencies]
nitrokey-test = {version = "0.1"}