aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-12-27 23:07:26 +0100
committerRobin Krahl <robin.krahl@ireas.org>2019-12-27 23:07:26 +0100
commit0bffc7931e011b4c0c046ed7608fbe9b7a1ffd19 (patch)
treec850d53faff809a8b3dcab68c16c2848c0c0c77e /Cargo.toml
parentc85f11a4d57bd8b3c2d5e00264eb27f06e8ae08c (diff)
downloadnitrokey-rs-0bffc7931e011b4c0c046ed7608fbe9b7a1ffd19.tar.gz
nitrokey-rs-0bffc7931e011b4c0c046ed7608fbe9b7a1ffd19.tar.bz2
Replace rand_os::OsRng with rand_core::OsRng
rand_os::OsRng has been deprecated. Instead we can use rand_core with the getrandom feature.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 320e69d..16bd3b0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,8 +20,7 @@ exclude = [".builds/*"]
lazy_static = "1.2"
libc = "0.2"
nitrokey-sys = "3.5"
-rand_core = {version = "0.5", default-features = false, features = ["std"] }
-rand_os = {version = "0.2"}
+rand_core = {version = "0.5.1", features = ["getrandom"] }
[dev-dependencies]
nitrokey-test = "0.3"