aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-07-16 08:58:37 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-07-16 11:00:20 +0200
commit6c138eaa850c745b97b7e48a201db0cbaad8e1e0 (patch)
treee3d202e09ec6c99054e7103578a961b949773709 /Cargo.toml
parentf150d59410eefdec2ae69b2422906a3d1d88aa07 (diff)
downloadnitrokey-rs-6c138eaa850c745b97b7e48a201db0cbaad8e1e0.tar.gz
nitrokey-rs-6c138eaa850c745b97b7e48a201db0cbaad8e1e0.tar.bz2
Update rand_{core,os} dependencies
This patch updates the rand_core dependency to version 0.5 and the rand_os dependency to version 0.2. This causes a change in util.rs: Instead of constructing an OsRng instance using OsRng::new(), we can directly instantiate the (now empty) struct.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 62eea02..a912859 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,12 +17,12 @@ license = "MIT"
exclude = [".builds/*"]
[dependencies]
-lazy_static = "1.2.0"
+lazy_static = "1.2"
libc = "0.2"
nitrokey-sys = "3.5"
-rand_core = {version = "0.3", default-features = false, features = ["std"] }
-rand_os = {version = "0.1"}
+rand_core = {version = "0.5", default-features = false, features = ["std"] }
+rand_os = {version = "0.2"}
[dev-dependencies]
nitrokey-test = "0.3"
-nitrokey-test-state = "0.1.0"
+nitrokey-test-state = "0.1"