aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <me@robin-krahl.de>2018-05-21 00:53:34 +0200
committerRobin Krahl <me@robin-krahl.de>2018-05-21 01:02:11 +0200
commit98eaf71502afeb4f14eb4f7bc365e3211b5709fb (patch)
tree9c3916298879769dd1adee622f007caae975eb11 /Cargo.toml
parent96b2f4bd20f81fdc1e57c004cd66d90221be6f87 (diff)
downloadnitrokey-rs-98eaf71502afeb4f14eb4f7bc365e3211b5709fb.tar.gz
nitrokey-rs-98eaf71502afeb4f14eb4f7bc365e3211b5709fb.tar.bz2
Update nitrokey-sys dependency to v3.3.0
Now libnitrokey v3.3 is compiled from source, fixing the problems with older libnitrokey versions (freeing strings, firmware version getter). Also, bindgen is no longer a build dependency. This makes the build process a lot faster.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d7f536e..134bf09 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,5 +17,5 @@ test-pro = []
[dependencies]
libc = "0.2"
-nitrokey-sys = "0.1.0"
+nitrokey-sys = "3.3.0"
rand = "0.4"