aboutsummaryrefslogtreecommitdiff
path: root/libc/libc-test/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'libc/libc-test/Cargo.toml')
-rw-r--r--libc/libc-test/Cargo.toml24
1 files changed, 22 insertions, 2 deletions
diff --git a/libc/libc-test/Cargo.toml b/libc/libc-test/Cargo.toml
index 9862d3a..8d2d903 100644
--- a/libc/libc-test/Cargo.toml
+++ b/libc/libc-test/Cargo.toml
@@ -13,8 +13,8 @@ cc = "1.0"
ctest = "0.2"
[features]
-default = [ "use_std" ]
-use_std = [ "libc/use_std" ]
+default = [ "std" ]
+std = [ "libc/std" ]
align = [ "libc/align" ]
extra_traits = [ "libc/extra_traits" ]
@@ -29,6 +29,26 @@ path = "test/linux_fcntl.rs"
harness = false
[[test]]
+name = "linux-ipv6"
+path = "test/linux_ipv6.rs"
+harness = false
+
+[[test]]
+name = "linux-elf"
+path = "test/linux_elf.rs"
+harness = false
+
+[[test]]
+name = "linux-strerror_r"
+path = "test/linux_strerror_r.rs"
+harness = false
+
+[[test]]
+name = "linux-termios"
+path = "test/linux_termios.rs"
+harness = false
+
+[[test]]
name = "cmsg"
path = "test/cmsg.rs"
harness = true