aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c81fbbf..b14fe0c 100644
--- a/meson.build
+++ b/meson.build
@@ -113,7 +113,12 @@ pkg.generate(
)
if get_option('tests') or get_option('offline-tests')
- dep_catch = dependency('catch')
+ dep_catch = dependency('catch', required : false)
+ if not dep_catch.found()
+ dep_catch = declare_dependency(
+ include_directories : include_directories('unittest/Catch/single_include')
+ )
+ endif
_catch = static_library(
'catch',
sources : [